US/Canada Toll Free Provider Maintenance

Incident Report for Modica Group Limited

Resolved

Moving this to scheduled maintenance.

Apologies for any confusion.
Posted Jan 13, 2026 - 14:17 NZDT

Monitoring

Our Toll-Free number provider has scheduled maintenance for 2026-01-19, 04:00 - 08:00 UTC.

Clients may experience delayed or failed Toll Free MT/MO traffic towards the United States and Canada.

If you have any troubles during this maintenance reach out to our support team.

Regards,
Modica Support Team
support@modicagroup.com
Posted Jan 13, 2026 - 13:52 NZDT
This incident affected: Mobile Operators (USA & Canada).