Campaign Manager - Upload List error - Work around available

Incident Report for Modica Group Limited

Resolved

Our Technical team has confirmed that the issue affecting list uploads in Campaign Manager has been fully resolved.

Clients can now successfully upload lists while creating a new Campaign without any errors.

Thank you for your patience while we worked to restore full functionality. If you experience any further issues, please contact our Support Team.

Kind regards,
Modica Support Team
support@modicagroup.com
Posted Oct 16, 2025 - 18:26 NZDT

Monitoring

Our Technical team have implemented a fix and we have successfully tested uploading lists to Campaign Manager when creating a new Campaign.

Clients are once again able to upload their Campaign List in the same step as creating the Campaign, or, you can upload the list first and then use the existing list when creating future Campaigns.

We appreciate your patience and hope the workaround didn't cause you any inconvenience while we worked to resolve this issue.

Please contact support if you're still experiencing issues.

Regards,
Modica Support Team
support@modicagroup.com
Posted Oct 16, 2025 - 13:02 NZDT

Update

Our team have identified the cause of the issue and are working to resolve it.

Please continue to use the work-around i.e. please upload your Campaign List in the Lists tab prior to creating your campaigns.

Anyone using existing lists will not be affected by today's issue.

Regards,
Modica Support Team
support@modicagroup.com
Posted Oct 16, 2025 - 11:30 NZDT

Investigating

We are aware of an issue with our Campaign Manager application.

Customers may be receiving errors when trying to upload a list while creating a new campaign, "An error has occurred creating quick campaign!"

Work-around;
Please note that Lists can still be uploaded in the Lists tab in the application and can then be used when creating a new campaign.

Our Dev team are investigating, we will post again once we have any updates

Regards,
Modica Support Team
support@modicagroup.com
Posted Oct 16, 2025 - 07:04 NZDT
This incident affected: Omni - Applications (Campaign Manager).