Delivery Issue United States - General Communication

Incident Report for Modica Group Limited

Resolved

This incident has been resolved.

If you have any troubles reach out to our support team.

Regards,
Modica Support Team
support@modicagroup.com
Posted Jan 28, 2026 - 18:57 NZDT

Monitoring

This incident has been resolved.

If you have any troubles reach out to our support team.

Regards,
Modica Support Team
support@modicagroup.com
Posted Jan 28, 2026 - 18:03 NZDT

Investigating

We are currently observing delivery issue to United States.

Incident Start Time: 2026-01-28 01:25 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

If you have any troubles during this incident reach out to our support team.

Regards,
Modica Support Team
support@modicagroup.com
Posted Jan 28, 2026 - 15:41 NZDT
This incident affected: Mobile Operators (USA & Canada).